黑锐源码社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 92379|回复: 9

[微鱼微擎微赞] 部分微擎模块出现“PHP script '****le.php' is protected by SourceGuardian and requires a..”错误解决办法

[复制链接]
  • TA的每日心情
    奋斗
    2019-4-4 14:14
  • 签到天数: 100 天

    [LV.6]常住居民II

    7693

    主题

    8623

    帖子

    202万

    积分

    齐天大圣

    Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19

    积分
    2020014

    宣传达人财富土豪优秀版主突出贡献活跃会员持久不泄

    发表于 2017-6-17 10:22:19 | 显示全部楼层 |阅读模式
    阿迪达斯70周年庆!大促!

    近期,由于部分模块已使用sg11加密方式,有的人使用模块出现类似如下错误:



    1. PHP script '****le.php' is protected by SourceGuardian and requires a SourceGuardian loader 'ixed.5.4.win' to be installed.

    2. 1) Download the required loader 'ixed.5.4.win' from the SourceGuardian site: http://www.sourceguardian.com/loaders/download.php?php_v=5.4.33&php_ts=0&php_is=4&os_s=Windows+NT&os_r=6.2&os_m=i586
    3. 2) Install the loader to ext
    4. 3) Edit D:\phpStudy\php54n\php.ini and add 'extension=ixed.5.4.win' directive
    复制代码


    解决办法:

    安装sg11扩展组件:关于SG11加密使用、安装配置说明教程 sg11加密组件安装步骤http://bbs.heirui.cn/thread-11282-1-1.html

    附带一个新手教程:

    已phpstudy环境组件为例:

    1、直接出现上述错误后,可以看到自己需要下载的sg11组件具体内容:“ixed.5.4.win”,直接去下载组件包,把ixed.5.4.win这个文件放到php的ext目录下,如下图:组件完全打包下载地址:http://bbs.heirui.cn/thread-11282-1-1.html

    2.jpg

    2、打开php.ini文件(就在你php版本目录下,不会打开的自己百度--


    增加一行代码:extension=ixed.5.4.win(你用的什么组件 就改成什么名字哦)


    3.jpg

    保存!

    3、重启web服务!即可完成安装

    提示:请确认按照上面的步骤操作完成且都正确,然后重启web服务,清除下浏览器缓存,重新登录微擎查看是否安装成功!



    锐币又不够啦,怎么办?①赞助黑锐,尊享全站任意下载特权>>
    ②您还可以充值锐币,用多少充多少!都是24小时自助,实时生效哦!

    该用户从未签到

    0

    主题

    3

    帖子

    5

    积分

    新兵蛋子

    Rank: 1

    积分
    5
    发表于 2017-10-5 03:59:29 | 显示全部楼层
    安装后,显示空白、、不显示错误代码了。 不知道到底哪里问题。 搞了半天。。。
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    79

    帖子

    379

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    379
    发表于 2017-10-18 13:50:21 | 显示全部楼层
    感谢,这东西又更新了啊!
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    51

    帖子

    651

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    651
    发表于 2017-11-2 00:19:50 | 显示全部楼层
    q3011028 发表于 2017-10-5 03:59
    安装后,显示空白、、不显示错误代码了。 不知道到底哪里问题。 搞了半天。。。 ...

    空白了说明安装好了,你没添加内容所以是空白的,我刚刚的也是这样子
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2018-7-17 19:50
  • 签到天数: 134 天

    [LV.7]常住居民III

    0

    主题

    153

    帖子

    153

    积分

    初入黑锐

    Rank: 2

    积分
    153
    发表于 2017-12-1 15:54:20 | 显示全部楼层
    您好,如果说空白是安装好了,只是 在未安装列表还是显示 未安装。再安装一次 是空白,还是显示没安装。谢谢
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-6-9 10:20
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    1

    主题

    1167

    帖子

    1479

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    1479
    发表于 2017-12-12 11:25:54 | 显示全部楼层
    老黑,为什么安装了,服务器都重启了,怎么还是一样的错误提示呢。?
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    奋斗
    2019-6-9 10:20
  • 签到天数: 9 天

    [LV.3]偶尔看看II

    1

    主题

    1167

    帖子

    1479

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    1479
    发表于 2017-12-12 11:26:27 | 显示全部楼层
    PHP script 'D:\webroot\x_cswxt\addons\hxq_lottery\inc\heirui\install.php' is protected by SourceGuardian and requires a SourceGuardian loader 'ixed.5.4.win' to be installed. 1) Download the required loader 'ixed.5.4.win' from the SourceGuardian site: http://www.sourceguardian.com/lo ... r=6.1&os_m=i586 2) Install the loader to ./ext 3) Edit D:\webroot\zzidcconf\php\php5.4\php.ini and add 'extension=ixed.5.4.win' directive
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    182

    帖子

    482

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    482
    发表于 2017-12-23 16:39:11 | 显示全部楼层
    感谢,这东西又更新了啊!
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    0

    主题

    93

    帖子

    393

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    393
    QQ
    发表于 2018-3-3 13:12:48 | 显示全部楼层
    阿迪达斯70周年庆!大促!
    PHP script '/home/u1049/ace/workspace/php/appcode/webroot/htdocs/addons/bianmin_tellist/module.php' is protected by SourceGuardian and requires a SourceGuardian loader 'ixed.5.5.lin' to be installed.

    1) Click here to download the required 'ixed.5.5.lin' loader from the SourceGuardian site
    2) Install the loader to /usr/aliyun/ace/softwares/eweb/php55/extensions/
    3) Edit /usr/aliyun/ace/conf/u1049/php/php.ini and add 'extension=ixed.5.5.lin' directive
    4) Restart the web server


    这个怎么处理,好像跟你们又不一样
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2016-7-11 16:44
  • 签到天数: 3 天

    [LV.2]偶尔看看I

    0

    主题

    84

    帖子

    384

    积分

    =钻石土豪=

    Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20

    积分
    384
    发表于 2018-6-13 19:10:30 | 显示全部楼层
    阿迪达斯70周年庆!大促!
    秋风十少 发表于 2017-11-2 00:19
    空白了说明安装好了,你没添加内容所以是空白的,我刚刚的也是这样子

    哪里添加内容呢?
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    2019,新的开始,黑锐与您一起放飞创业梦!加盟渠道代理,月入万元不是梦!详情咨询 代理特权:1、无限制获全站所有资源! 2、独家获取官方超优质一手资源! 了解更多 ×


    免责声明:
    黑锐论坛所发布的一切破解版源码、破解补丁仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序、源码,请支持正版源码、软件,购买注册,得到更好的正版服务。

    Mail To:iheirui@Foxmail.com

    QQ|Archiver|手机版|黑锐源码社区 ( 川公网安备 51012402000122号 | 蜀ICP备19006044号-2

    GMT+8, 2020-5-25 17:56 , Processed in 1.212027 second(s), 44 queries , Gzip On.

    Powered by Discuz! X3.2

    © 2014-2017 Heirui Inc.非法入侵必将受到法律制裁 法律顾问:成都公生明律师

    快速回复 返回顶部 返回列表



    ====快捷导航====关闭